AWS Outage Impacting Integrations and License Services

Incident Report for Fishbowl Solutions

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 22:06 UTC

Identified

AWS has reported that a fix has been implemented. We will continue to monitor the situation..
Posted Oct 20, 2025 - 19:11 UTC

Investigating

We are aware of an ongoing AWS outage impacting multiple Fishbowl integrations and license key validations.
Our engineers are closely monitoring the issue and will provide updates as soon as AWS service is restored.
Thank you for your patience as we work to minimize disruption.
Posted Oct 20, 2025 - 14:50 UTC
This incident affected: Fishbowl Drive (Fishbowl Drive Webapp, Fishbowl Drive API) and Fishbowl Advanced (Fishbowl Advanced Plugins).