Fishbowl Hosting performance degradation

Incident Report for Fishbowl Solutions

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 18, 2025 - 19:38 UTC

Investigating

We are currently investigating the issue with performance issues and being unable to connect to Fishbowl Hosted services.
Posted Dec 18, 2025 - 14:41 UTC
This incident affects: Fishbowl Hosted Services (Remote Desktop Services).